Downtime has not been completed for 1.4.0

Incident Report for Nintendo Switch UI Demo

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 19:25 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2025 - 19:15 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 04, 2025 - 19:00 EDT

Investigating

Downtime has not been completed yet and has shown an incorrect message for the status page. We are working to resolve this issue. Thank you for your patience.
Posted Apr 04, 2025 - 18:51 EDT
This incident affected: Website.